Monday, June 18, 2012

Six Updater v2.9.6pre43 released!

Launcher build: 1.0.0.91
Available on auto-update and the Download section.

Launcher Changelog


Additions

  • Added EU and updated Empty flags
  • Added "Previous Mod" cycle
  • Added server count
  • Added server protection level (based on Signatures and BattlEye)
  • Added support for launching through the Steam Launcher
  • Added support for the Unsung mod to the Launcher
  • Added support for the vanilla game (with and without the beta)

Changes

  • Changelog is optionally shown after updating a Mod
  • Double clicking a server in the server browser joins the server (after update if required)
  • Enabled hint error dialogs for known issues (esp ones caused by issues with the user system)
  • Improved auto-updater reliability
  • Improved Beta support
  • Improved setup/upgrade reliability
  • Improved support for Unicode
  • Mirrors are prioritized by latency
  • Robocopy is used instead of rsync for custom repositories when the Remote is actually a local folder
  • Synchronizations after startup will no longer block operations
  • Server Name is now colored (White: Mod version match, Yellow: Requires update, Gray: Server is outdated)
  • The Game Path for ARMA2 Original can now also be configured manually in the Options
  • Updated GeoIP db for more accurate server country flag assignment
  • Warn the user when trying to join a server with outdated mod version

Fixes

  • Inconsistent case usage of verifySignatures and gameState, caused invalid server status
  • Main button chrome was visible due to rounded corners background
  • Memory leak during Synchronization
  • Unhandled exception on corrupted configuration file
Several other small fixes and improvements

Please report any issues or feedback at the Support section.

Enjoy and stay tuned for more updates!

No comments:

Post a Comment